chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
I'm using Visual Studio 2005 with TypeMock 4.1.0 installed. I have a typical unit test project loaded. The test I want to run uses mocks. Everything runs as expected. I then select "Create Performance Session" for the test and attempt to measure performance. I get a TypeMock error saying that TypeMock is not enabled. Of course it's enabled. There's some disconnect between TypeMock and the performance tool. I checked the TypeMock configuration window which tells me that there are no products that TypeMock might link to.

Please advise. At this point I'm trying to rewrite the test to not use TypeMock.
asked by stimsonr (2.1k points)

2 Answers

0 votes
Hi

First I apologize for the late reply :oops:

The error message is correct: since both the Isolator and and performance tool are profilers you need to link the tools in order to let them work togther.

Unfortunately we don't have integration with VS performance tool and that's why can't see it the profilers list.
answered by ohad (35.5k points)
0 votes
Hi
Please ignore my previous post. :shock:

since the VS profiler is not doing code insertion at run time you don't have to explicitly link the Isolator with it.
It will help if you can send us the solution with the problem. I'll send you a mail from our support, please reply to it and attach the solution.
answered by ohad (35.5k points)
...