chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
Hi,

What could be causing the trace tool to not capture anything?

Thanks,

Jason
asked by JasonW (2.3k points)

6 Answers

0 votes
Hi Jason,

Can you please post the test and describe what were you doing?

Regards,
Elisha
Typemock Support
answered by Elisha (12k points)
0 votes
Elisha,

Isolator Tracer is not capturing any of my AAA mocks. I would start the tracer from Visual Studio 2008, then run my unit tests. For some reason, the tracer would not capture anything even though all of our mocks in the unit tests are working.

Jason
answered by JasonW (2.3k points)
0 votes
Hi Jason,

Can you please give more details about the environment you are running?
What's the operating system?
Is it 64 bit OS?
What test runner are you using to run the tests?
answered by ohad (35.5k points)
0 votes
Windows 7 Professional 64bit

Using TestDriven.NET to kick off MSpec.


Hi Jason,

Can you please give more details about the environment you are running?
What's the operating system?
Is it 64 bit OS?
What test runner are you using to run the tests?
answered by JasonW (2.3k points)
0 votes
Hi,

Thanks for the info.
Can it be that the TestDriven process is running with different security privileges than the tracer?
answered by ohad (35.5k points)
0 votes
Environment:
Windows 7 Enterprise x64 (joined to a domain)
Visual Studio 2008 SP1 Team Suite
Using Visual Studio's test runner

The only way I can get something into the Tracer is if I'm running both Visual Studio and the Tracer As Administrator.

If I run Visual Studio As Administrator and Tracer not, the tests run extremly slow.
answered by paulo.morgado (11k points)
...