chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I'm currently trying to evaluate Typemock Isolator 6.0.8. After installation, when trying to open a solution with VS2010 Premium SP1 (running on W7 64 bit) results in a VS crash.
When trying to open VS2010 without any solution, VS starts, but often crashes again when loading the solution. If I manage to load the solution successfully, it always crashes when switching from Debug to Release or vice versa (Application is not responding).
Also running a build of installer projects (WIX 3.5) results in an error.

If I uninstall Typemock, all those issues are not occuring until the next re-install. So this is consistent.

I'm also using some other plugins (ReSharper 5.1, dotCover 1.1 RC).
Unfortunatly this makes Typemock currently unusable for me.
asked by akrebs (760 points)

6 Answers

0 votes
Hi,

Thanks for the report.
Do you see a message box with an error message when you first start visual studio?
answered by ohad (35.5k points)
0 votes
Yes, it's a message box "Microsoft Visual Studio has stopped working" with the usual options to check online for a solution, close and debug.

The problem details are:

Problem signature:
Problem Event Name: APPCRASH
Application Name: devenv.exe
Application Version: 10.0.40219.1
Application Timestamp: 4d5f2a73
Fault Module Name: StackHash_9e5b
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c000041d
Exception Offset: 75484cad
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 9e5b
Additional Information 2: 9e5b9abab5b673528aeb76682be2c1c1
Additional Information 3: d3c5
Additional Information 4: d3c56bf6c467bf90374ad3bcaf945368

This error I'm getting always when trying to open a solution directly without starting VS first.
answered by akrebs (760 points)
0 votes
Hi,

We uploaded a new version today that should fix the issue.
Please try it and let me know if it fixed the problem.
answered by ohad (35.5k points)
0 votes
Hi,

I tried with the new version and everything worked fine right after installation. After closing VS it went back to the same behavior.

So VS hangs when directly opening a solution with:

Problem signature:
Problem Event Name: APPCRASH
Application Name: devenv.exe
Application Version: 10.0.40219.1
Application Timestamp: 4d5f2a73
Fault Module Name: StackHash_9e5b
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c000041d
Exception Offset: 75484cad
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 9e5b
Additional Information 2: 9e5b9abab5b673528aeb76682be2c1c1
Additional Information 3: d3c5
Additional Information 4: d3c56bf6c467bf90374ad3bcaf945368

When starting VS and opening the solution from within VS, it works until I switch the build configuration from Debug to Release with the following error:

Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: devenv.exe
Application Version: 10.0.40219.1
Application Timestamp: 4d5f2a73
Hang Signature: 5197
Hang Type: 0
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Hang Signature 1: 51973f2c4dc7734113ad749bd5e0cb50
Additional Hang Signature 2: a377
Additional Hang Signature 3: a3772aaff245223eced1ce1111a5feda
Additional Hang Signature 4: 5197
Additional Hang Signature 5: 51973f2c4dc7734113ad749bd5e0cb50
Additional Hang Signature 6: a377
Additional Hang Signature 7: a3772aaff245223eced1ce1111a5feda

Also the build error for installer files appears again.

I should mention that my solution containes 50 projects with custom build steps.
answered by akrebs (760 points)
0 votes
Hi,

Indeed there still is a problem with this version, and it will be fixed in the next few days.

In the meanwhile, try installing this patch (uninstall, and install):
https://www.typemock.com/patches/Typemoc ... .8.483.msi

Sorry for the inconvenience...

Regards,
Yonatan,
TypeMock Support Group
answered by yonatan (1.6k points)
0 votes
Ok, so I did some more playing with the configuration of my setup. I updated ReSharper to the latest EAP build (6.0.2155), uninstalled dotCover and now VS doesn't crash anymore.

So that part is fixed by now, but it seems there's an issue when using all of the above.

The issue with WIX Installer builds failing persists though, this is the error I'm getting:
Error 26 An error occurred generating a bootstrapper: Unable to begin updating resource for binRelease\en-ussetup.exe with error 80070002 Z:svnMyProject.InstallerMyProject.Installer.wixproj 338 6

This is not critical since I don't need the setup.exe, the .msi file is built just fine.

I did these tests with the Isolator Version 6010 (posted above).
answered by akrebs (760 points)
...