chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
hi

we need to upgrade to 7.4.2 because we use VS 2012, but we also need to support solutions that use 7.1.6. I can't run the 7.1.6 tests with 7.4.2 TMockRunner because I get a blow up (using command lines)

Can I have the latest TMockRunner 7.4.2 run tests against 7.1.6?

I understand about autodeploy on the build servers, but his is local to the dev.

Thanks in advance!
dan
asked by dannyb (3.1k points)

1 Answer

0 votes
Hi Danny,

I tried to reproduce this issue, this is what I did:

Part 1:
  1. Installed version 7.1.6.
  2. Compiled the examples in VS 2010.
  3. Copied the binaries to a different location.
    Typemock Binaries(all version 7.1.6):
    • Configuration.dll
      Typemock.ArrangeActAssert.dll
      TypeMock.dll
    Test binaries:
    • Typemock.Examples.CSharp.dll
  4. Installed version 7.4.2.
  5. Compiled the examples in VS 2010.
Part 2:
Using TMockRunner 7.4.2 to run tests referencing 7.4.2:
"C:Program Files (x86)TypemockIsolator.4TMockRunner.exe" "C:Program Files (x86)Microsoft Visual Studio 10.0Common7IDEMSTest.exe" /testcontainer:"C:7.4.2Typemock.Examples.CSharp.dll"

Using TMockRunner 7.4.2 to run tests referencing 7.1.6:
"C:Program Files (x86)TypemockIsolator.4TMockRunner.exe" "C:Program Files (x86)Microsoft Visual Studio 10.0Common7IDEMSTest.exe" /testcontainer:"C:7.1.6Typemock.Examples.CSharp.dll"


Both commands ran the specified test dlls and all tests passed.

Please let me know if it helps(in case it doesn't,send us an error message or a dump file with the record of this issue).
answered by alex (18k points)
...