chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes

I have just updated to the latest version of Typemock Isolater, 8.2.3 from 7.5.1. Tests are running fine when I run them through Test Driven.net.  When I run them through the type mock test runner, I am getting an error that log4net could not be loaded.  The application I am testing uses 2 different versions of log4net. Some 3rd party assemblies used an older version of log4net that had has a different public key token than then newer version. To get around this issue, we have a binding redirect in app.config like this

 <dependentAssembly>
        <assemblyIdentity name="log4net" publicKeyToken="1b44e1d426115821" culture="neutral" />
        <codeBase version="1.2.10.0" href="log4netv1.2.10.0\log4net.dll" />
      </dependentAssembly>
 
Notice that the dll is in a folder deeper in the bin directory. The current version is in the root of the bin.
 
I am not sure why the typemock test runner loads assemblies but this scenario is not working.  Test driven.net handles it just fine.
 
Also, I can no longer run tests through the vs.net test runner.  Is this no longer supported?
 
Thanks,
Jesse

 

asked by juice_johnson (9.3k points)

1 Answer

0 votes
 
Best answer

We're about to release a new version which may solve this issue.

Can you try it and let me know if it helps?

www.typemock.com/files/patches/TypemockIsolatorSuite-8.3.0.98.msi

answered by alex (18k points)
selected by alex
This does solve the issue.

Thanks you.
...