chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I get this error whenever I call MockManager.Init().

I'm running a plain WinXP SP2, NOT a 64 bit version. I do have AMD 3500 CPU however.

Error tells me to install TypeMock x64 and obviously I get "unsupported processor type" when I try.

Any suggestions?

Thank you.
asked by alexg (680 points)

7 Answers

0 votes
The error you are getting is incorrect, we should fix it.
The error you are supposed to get is:

TypeMock.NET is not enabled, to enable do one of the following:
1. run 'mocking_on.bat' before running the tests
2. run tests via TMockRunner.exe
3. use TypeMockStart tasks for MSBuild or NAnt
4. set Tools->Enable TypeMock.NET from within Visual Studio
For more information consult the documentation (see Running topic)


In any case make sure that the TypeMock reference is to the correct version
answered by scott (32k points)
0 votes
- I'm running from VS.NET 2005.
- I'm showing "Diable TypeMock.NET" in "Tools" menu which I assume means that's it's currently enabled.
- I'm running via csUnit VS.NET Addin (which I hope is the same as running NUnit addin).

- I have also tried executing the following statement from the folder where test files are (including TypeMock.dll and full absolute paths everywhere)

"....\TMockRunner.exe" "....\csUnitCmd.exe" /assembly:....\Tests.dll"


here's what I got from that:

Starting to execute tests...

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'TypeMock, Version=0.0.0.0, Culture=neutral, PublicKeyToken=0000000000000000' or one of its dependencies. The system cannot find the file specified.
File name: 'TypeMock, Version=0.0.0.0, Culture=neutral, PublicKeyToken=0000000000000000'
   at csUnit.Interfaces.AssemblyEventArgs..ctor(String assemblyFullName, String assemblyPathFileName)
   at csUnit.Core.Loader.ThreadProc()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
answered by alexg (680 points)
0 votes
Please try the following:
1. Open the GAC (Windows\Assembly) and tell me what versions of TypeMock are installed
2. Run the command line TMockRunner –logPath=<somePath> …
Send me the *.log files created in that path (I have sent you the e-mail address)
answered by scott (32k points)
0 votes
sent
answered by alexg (680 points)
0 votes
I am getting the same problem in my machine.
Please let me know if you have found a solution to this problem.
answered by siji_varghese (140 points)
0 votes
Please make sure that you have enables TypeMock.
here are some ways to do it:
1. using TMockRunner.
2. using NAnt/MSBuild tasks
3. using the Visual Studio Addin - remember to restart the test process.
answered by scott (32k points)
0 votes
This is fixed in version 3.6
answered by scott (32k points)
...